You are here:

System Requirements for Remote Desktop

Your computer must meet the Cloudnine System Requirements and it must have the latest updates installed:

If you are not working from a Windows 7 computer (or later version) you will need to upgrade to Windows Service Pack 3 and the latest version of Remote Desktop Protocol (RDP). You will also need to upgrade your printer drivers to the latest versions.

Note: RDP Port 3389 is required to be opened on your firewall to connect to Cloudnine.